Grasshopper

algorithmic modeling for Rhino

Hello and thank you for your great tool! I am trying to connect Wallacei with the zombie kangaroo solver, but the results are completely different from we you use Galapagos. Is it possible to connect Wallacei and Kangaroo?

Views: 108

Replies to This Discussion

Hi Juanfra,

 

Of course, yes. it is possible to connect Wallacei with Kangaroo Zombie Solver. However, your question is very unclear, there might be a lot of reasons that you see different results. For example, what kind of optimization problem you are running? Single objective or multi-objective? Keep in mind, Galapagos can only run single objective optimization. Are you minimizing or maximizing? what are you optimizing for? please post your file and clarify your question otherwise I cannot help you. David has a great post of an example of how to ask effective questions, check it out here: https://discourse.mcneel.com/t/how-to-ask-effective-questions/50034

 

Best,

Milad  

Hi Milad,

Thank you very much for your quick response. I apologize for not being more precise, I hope to make it right this time.

I've prepared a dummy file showing the behavior I'm experiencing. When I modify the slider before introducing Wallacei (later used as gene), the zombie solver gives very different solutions to when connected to Wallacei. Moreover, once the optimization is finished or aborted, it seems that the definition is affected and does not return to its initial state until it is recomputed.

I have attached a short video and the gh definition

https://www.dropbox.com/s/cfkeimxhvtueqtk/Wallacei%20%2B%20Kangaroo...

Best
Juanfra

Attachments:

Juanfra,

Now your question and problem have become very clear. The answer is the number of iterations of zombie solver, in your GH file this number is 1, of course, 1 is not enough iteration to converge to the optimal solution in Kangaroo Zombie Solver. Check out the video below. You need to increase the number of iterations in Kangaroo Zombie Solver. You can read more about Kangaroo in Kangaroo page (http://kangaroo3d.com/), great work by Daniel Piker.

https://drive.google.com/open?id=1DBMoRI8C6Q2bwm0Tfp1xQjx0Bk7VgqS8

Thank you so much again for your time. In my case the anomalous behavior persists. Even after updating Wallacei to its latest version. I am also using:

Rhino version 6 SR14 (6.14.19118.15561, 04/28/2019)

Grasshopper 1.0.0007 version Sunday, 28 April 2019 15:56

https://www.dropbox.com/s/bhdw64uxcxy6usr/Wallacei%20%2B%20Kangaroo...

I can not recreate your problem here on my side, I even used a different machine but still cannot create the problem. however, I noticed you are not using the latest Rhino/Grasshopper.

Update to the latest releases, 

For Rhino: Version 6 SR14
(6.14.19127.17141, 05/07/2019)

once you update the Rhino 6, GH will be updated accordingly. 

Let me know if this solved your problem. 

I have just updated and same result, still the same behavior. Could you please upload the gh file which is working for you?

please find the file attached, it is actually your file. 

Attachments:

I know, it was just for trying anything, but again is the same behavior for me. 

If you have any more ideas about what might be going on, please let me know.

Thank you very much!

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service