Grasshopper

algorithmic modeling for Rhino

Problem with integrating Physical simulation and Wallacei X

Hi guys

I am new to this group and I am very excited about using Wallacei X for my upcoming project. 


For the moment I am running an experiment that attempts to integrate Wallcei with a timed Flexhopper component. The objective of this script is to establish a simulation loop in which Wallace takes results from the particle simulation as fitness objectives, and produces new geometries for a new round of simulation/evaluation.

(as you can see here whenever an input value is updated a new round of particle simulation will be triggered until counter reaches a pre-determined value)

Right now it appears that Wallace does not wait for the fitness objectives to update and simply goes ahead changing the genetic inputs.

This does not give Flexhopper any time for simulation. Could you guys take a look at the script and point out when I might've got things wrong? 

Best Wishes 

Views: 61

Attachments:

Replies to This Discussion

 In my previous GH file there are some components unnecessary for debugging. I have swapped them out and replaced the counter with a python script. much appreciated 

GH LINK

Hi William,

I don't have Flexhopper installed at the moment, but by looking at your pseudocode and the screenshot you posted I can imagine what is happening there. I am not familiar with Flexhopper a lot but I assume that Flexhopper particle simulation is a timer-based operation with live results. Right? Is there anything like Zombie Solver in Flexhopper workflow? Something like Kangaroo Zombie Solver? Zombie solver is basically the same as the live solver but instead of calculating everything live, it just spits out the final results after the predefined number of iterations (in your case would be your particle behaviours/positions after a number of iterations). If there is such solver in Flexhopper workflow, I recommend using that one and your problem should be fixed.

If there is no such thing in Flexhopper workflow, then I need more time to look at your problem from my end.  But I am afraid with the current public release of Wallacei, you may not be able to have both live loops running at the same time (Flexhopper loop that updates particle simulation in each iteration, and the bigger Wallacei generative loop of the entire workflow).

Hi Milad 

Thank you for your reply. I have been researching flexhopper this weekend and there is a setting that enables "zombie mode". In the "flex option" component there is a fixed number of iteration setting.

This allows the outputs to be calculated internally instead of being animated frame by frame. 

However even with this option enabled, the previously described problems still persists. In addition there seems to be a memory spike that triggers crash every single time. (if the total Wallacei population size is bigger than 200)

Again thank you so much for your time and your reply !

Here is the new GH canvas and Link for the GH file

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service