algorithmic modeling for Rhino


I've read up on the previous posts regarding Ladybug and Wallacei.

I've tried running a script on Rhino 5, that takes a few sliders as Genes, and the Total Radiation output from the Ladybug Radiation Analysis component as the Objective.

Rhino keeps crashing as soon as I "start". I tried even 1x1 for the Generation Size and Generation Count.

Following a post here in the forum, I've 'internalized' the _selectedSkyMtx data, so that Wallacei will not re-calculate it for each generation.

I've also updated Ladybug to, and I've tried running the Wallacei simulation on Rhino 6 as well.

but none of these solutions work...

Doesn't someone have an idea what the issue is?

Note: The Ladybug simulation itself works perfectly on a given Brep.

Views: 345

Replies to This Discussion

Hi Yafim,

Can you please upload your GH file. It makes it easier for us to find where the problem is.






Thank you, Yakim.

I ran your file and as you can see, Wallacei ran the simulation smoothly on my machine. I am using Rhino 6 (sr13), the recent version of Ladybug (0.0.67) and the recent version of Wallacei (2.1). I have also internalized the Skymatrix and disabled that component as it increased the speed significantly.

However, I did a slight change in your definition. Instead of reading the epw file locally from my machine I used the other ladybug component that reads the epw file from the URL. Please try this method on your machine and let me know whether it fixes the problem on your side or not.

More importantly, since I can’t replicate the problem on my machine. you’ll have to go through some debugging steps to find where the issue lies. What I would do is go back to the original definition and build it ‘piece by piece’.. I.e. start with the first few components in your definition and run Wallacei. and keep adding to the definition bit by bit, running Wallacei at every interval until you face a crash. That way we will be able to narrow down the component causing the problem and then I can look into it more closely.

It is a bit tedious I know, but the above should take you no more than 30 mins, and hopefully, by the end, you will know which component is causing the problem.

Let me know how it goes.

Hi Milad,

Thanks for the help!

1. I removed the entire Ladybug definition from my file and left only the generated curve geometry for the tower.

2. I ran the simulation of 3x3 in Wallacei for only the exterior surface of my Loft component, which ran well, and then I "Capped" the surface to get a full Brep geometry and ran the 3x3 again. It ran fine as well.

In both cases above (surface / capped brep), the Objective was the "Area" component.

3. I pasted my Ladybug definition again, which reads an error of:

"1. Solution exception:unsupported operand type(s) for -: 'str' and 'int'"

in the radiation component.

4. I linked the online .epw again to the radiation component and re-internalize the data, and then disabled the components again as mentioned before to lighten the simluation.

Then I ran the 3x3 simulation again, but it failed.

So i'm guessing this has something to do with the capacity of Wallacei to handle the radiation analysis in Ladybug, because that's what's causing the crash.

Any ideas on a possible solution?

Thank you


I ran your exact GH definition with three different machines, and in all of them, Wallacei works smoothly. I am afraid the problem may stem from your machine/setup. Please make sure you have the latest Rhino 6 update (sr13) and the latest Ladybug (0.0.67) and Wallacei (2.1). I think it is worth trying to re-install them cleanly from the beginning as well.

Also, since I cannot recreate your problem from my end with different machines, a little bit more information about your setup might help us to find the problem, can you give me more info on your machine? (type in the rhino command _systeminfo and paste the result here)


Ps: pay attention to number 3 you posted. I recommend testing in a new Grasshopper file.

I'm betting my money on the fact that I'm using Rhino 5, even though I did try it on Rhino 6 as well.

I'll get a fresh license and try it out again from the start to see if that solves it.

Thank you for all the help, i'll update as soon as the test happens.






  • Add Photos
  • View All

© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service