Grasshopper

algorithmic modeling for Rhino

Hi Santiago -

Skin Designer is fantastic! Really excited to use it. I recently installed the latest 2018 version, and am having trouble with the new version of the panel bay tool. When I connect what seem to be valid panels to the component (I can see them individually with panel viewers) I get a null output. Please see attached image. Trying to view the panel bay with panel viewer fails due to not receiving valid input. I also tried testing the component internally with the test button and it seems to work. See attached file. Still, the panel bay component output is 'void' and it does't send data further to the skin generator. I am Rhino 6 with units as feet and tolerance at .01. Please let me know how to fix this. 

Thanks very much,


Matthew Winkelstein

SERA Architects, Oakland

Views: 341

Attachments:

Replies to This Discussion

Hi Mathew,

Glad to hear you are enjoying the tool. The issue in this case is a very simple one. Seems I mistyped the output name, it should say "panelBay" altogether without the underscore. You can easily rename the output by right clicking on it and editing the name shown at the top of the options. Please let me know if you have any issues with that, I can send you the corrected component otherwise. 

Thanks for pointing this out Matthew, I will update the component on the github as well.

Santiago

Awesome! Thanks, Santiago. That did the trick. 

I am now having a different issue however. The basic panel tools work just fine for a while, but then later when I re-run the boolean toggle to reactivate the components suddenly the tool turns orange and gives me a warning: 1. Internal Warning: Panel Parameter CustomGeoController is not valid. Once this happens the component won't work anymore, no matter what I try. It also sends something downstream to the panel viewer, turning it red with: 1. Solution exception:unsupported operand type(s) for +: 'str' and 'NoneType'. Also, once this happens to one panel component, it happens to all of them in the definition. Odd... Attaching the gh file and some screen shots.

Thanks!


Matthew

Attachments:

Hi Mathew,

This issue comes up when you open a different gh file with the previous version of SkinDesigner (0.1). Basically it reverts the Panel code the the older version, triggering the error.

I would suggest having only SkinDesigner 0.5 open in your canvas, otherwise you will need to "recompute" each file to rerun their version of the SkinDesinger-SkinDesinger component each time you switch between them. ALos note this will cause some panel and skin geometry generated in the scene to "unlink" from SkinDesinger and will have to be deleted manually. Ideally, again,  I would stick to one SkinDesinger version at a time if possible.

Hope this does the trick, please let me know otherwise.  Clearly the transition between the two versions has some not that well documented issues. Thanks for helping bringing them up.

Santiago

Thanks - seems ok now.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service