Grasshopper

algorithmic modeling for Rhino

Octopus cannot start computing - phenotype? too fast for loops?

Hello all,

I am having a problem with figuring out why Octopus cannot compute anything.

The case is sailing yacht's rig (mast, spreaders + steel lines) multicriteria optimisation.
The 1st criteria is to minimize the mass, the second to minimize the VCG (vertical center of gravity).
As a genotype for now I've connected only the number of spreaders (see picture below for explanation).


Two questions arises here:

1. The 1st thing is I am not sure what to connect to the Phenotype input.
In all the examples it is more straihg-forward - you plug in domain for points (i.e. surface) and the solution is a point.
In my case I change the number (of spreaders) and get all the geometry from the photo.

I tried to connect the whole geometry - so all lines that represent: mast, spreaders, steel lines,
but Octopus does not "want" to start - it seems that he calculates something - evaluation time displaying on the left etc.
But nothing appears on the chart.
From the other hand it doesn't crash either.


2. Judging on what I see in Rhino, Octopus rarely wait till GH finishes calculating the whole geometry.

The problem is it takes a while - I've usen "time buffer" component with delay set to 8(!) seconds, so all the loops finishes and total mass that appear is the final one.

Any ideas how I can make him wait?

Thanks,
Nicolas

Views: 259

Replies to This Discussion

Now I am sure that Octopus changes the parameter so fast that he does not get any data from GH.

Do you have any examples how to make the Octopus wait for the new result of fitness function after changing the sliders?

If anyone has a similar case - it was the delay component.
After cutting it off and connecting all geometry to phenotype Octopus has started,
although still not working properly - still haven't solved the 2nd problem.

https://discourse.mcneel.com/t/grasshopper-octopus-how-to-stop-data-before-octopus-gets-it/83090

Hi, Mikolaj, Have you solved the problems? 

I have the similar problems, I want to get the last output values as a condition to connect gene pool, (it should be connected to octopus's  O  location), but it doesn't reach my goal.

So, how to make the octopus run slowly ?  Thank you!

Hi zcLIU,

I haven't solved that particular problem.
The root of if was Karamba that was throwing out zeros before giving the correct values of evaluated forces in the yacht's rig (so the Octopus was fed by it with two sets of data at one step). As I haven't found any other option I have done the calculations by myself (without any plug-in) to avoid using Karamba and it helped. I noticed that Octopus gets confused when getting the data from different sources not at the same time and unfortunately haven't found a way of delaying the data that doesn't affect the Octopus.

Hope it helped.

Hi  Mikolaj,

Thank you for your message.

Have you notice the topic about this, 

https://discourse.mcneel.com/t/octopus-uncomprehensive-results/56338/5

robert_vier replies one answer:

what does his means?  When using Octopus, We can't connect any batteries with octopus's G and O port except for gene pool、silders or number ?

Thanks.

Haven't seen that topic.

What I think he means in the post you linked is the same to what I said, but with some technical explanation. He's basically saying that all stuff delaying data (as dataDams i.e.) will most likely disturb the correct behavior of Octopus. 

Haven't seen the whole topic, but in this particular post he doesn't say anything about leaving the 'G' or 'O' port empty.

All right. :)

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service