Grasshopper

algorithmic modeling for Rhino

Hie,

Thanks for the work on Gismo, it looks great.

I'm fighting a little to get the workflow correctly going.

The Analysis terrain tool isn't reconizing the terrain input. I tried with ladybug and with gismo terrain generator, and they seem to work fine.

This problem may be trivial, and I'm sorry to bother.

Any idea ?

Views: 413

Attachments:

Replies to This Discussion

Hi Georges,

Here it is.

Thank you to take time for it.

Attachments:

Hi Denis,

What I thought is that if you could run the "Terrain Generator" component, and then use the "geometry" parameter for each on if its outputs. Then you click on the parameter, and choose "Internalize Data". You do this for each of the outputs ("readMe!" is not necessary). You save such .gh file and upload it.
You will probably have to upload it somewhere else, as grasshopper3d forum accepts attachments up until 5mb in size.

Hi Djordje,

Here it is, as I understand it.

I internalised input datas of terrain analysis and flow component out of terrain generator(as it seems to me that only input datas can be internalised);

First thing is : the file is not that bigger than before.

Hope you'll find out what is happening.

Attachments:

Hi Denis,

Thank you for attaching the file.
Everything works without any issue when I open your file: the "Terrain analysis" component analyzes the internalized terrain surface.
I am not sure what can be the issue in your case.

Can you try to maybe right click on the "_terrain" input of the "Terrain analysis" component and then choose "Type hint -> Brep".

Then recompute the grasshopper definition: In Grasshopper's top menu: Solution->Recompute.

Hi,

I tried. the component went from orange to red and answers that in french :

1. Solution exception: Impossible de traduire les octets [E8] à l'index 0 à partir de la page de codes spécifiée en Unicode.

Do you think that full re-installation of rhino, grasshopper, gismo could solve that problem ?

Denis

Honestly I do not know what causes this error.
Can you try to run the following definition below?

I grouped the two boolean toggles that need to be run in red color.

Attachments:

I doen't make better.

The error message gives another clue. What about unicode ?

"1. Solution exception:Impossible de traduire les octets [E8] à l'index 0 à partir de la page de codes spécifiée en Unicode."

https://unicode-table.com/en/

Does it have any importance related to gismo ?

Can it be related to special characters you have in the path of your machine?
I believe it is related to something on this direction.

Can you check it? Where the files are saved and so on?
-A.

I solved the problem by setting the rhino file unit system to inches...

Thanks to all for your help.

Hi Denis,
This is very interesting solution.
So you generate the terrain first (with units set to Meters in Rhino for example), and then you set the Rhino units to Inches and rerun the grasshopper definition. This makes the "Terrain Analysis" component to work?

Yes. I can switch meters/inches, recompute the gh definition, and analysis component goes red/on

Thank you for the reply Denis. Not sure what can be the reason though.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service