algorithmic modeling for Rhino

I've just started using the "Create Text on Layer" component, and am unable to get any font to load. I'm following the syntax (Arial-Regular) and have tried a few different fonts, but keep getting the following error: 

1. Solution exception:Member not found. (Exception from HRESULT: 0x80020003 (DISP_E_MEMBERNOTFOUND))

Anyone else had an issue like this?

Views: 275

Replies to This Discussion

Hi. Are you asking in regards to Doodlebug?  I only compiled the plugin against newer version of Illustrator, but am not working on it. If you post the question to the group, then you might find some answers. Thanks.

Hi Scott - do other components work? This looks to be a COM interface issue (notoriously tricky to troubleshoot) which may have to do with building against a different version of Illustrator. What version of illustrator are you running? 

Other components are working fine. I'm running Illustrator 2015.

Hi Andrew, I put this issue to rest for a while and came back to it today. I thought using your Font Table component from Human might solve the issue (rather than typing in a panel), but that didn't work either.

I tried to recreate the issue at home to see if it was the Illustrator version, but realized that whatever version I had (I'm running 2017, using a version that someone posted on this forum) didn't have the Create Text on Layer component. Any insight about this issue lately?






  • Add Photos
  • View All


  • Add Videos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service