algorithmic modeling for Rhino

I kept getting this error when trying to use Doodlebug: Solution exception:Retrieving the COM class factory for component with CLSID {B0D0A647-983E-485B-9A69-45F0382F0D9C} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)). I'm not familiar with a lot of the magic and programming languages behind how this plugin works between Rhino and Illustrator, but I did a bunch of prodding trying to find a way to use Illustrator CC 2017 with it.

In the end I couldn't. But I installed CC 2015 (19.0.0) and it worked perfectly. This is on my personal laptop running Windows 10, with Illustrator installed at its default position on the C drive. No other more recent version worked for me, but I think that's more of a problem with my own dying laptop.

Views: 4039

Replies to This Discussion

Hey Chuck Thanks for the DL this worked for me!!

Playing around with it I've tried to create something similar to what you show in the gif on your website Andrew. So far it looks like its sending to illustrator the curves stacked in a top view. Am I missing some sort of 3d view in illustrator. Or a specific viewport to send from GH?



For some reason I don't have a "Reply" button for your last post.

"RhinoCommon" I was able to relink. I don't have Grasshopper in my Rhino folder under appdata. Instead it is broken out as its own program. I checked to make sure I'm on version .76 and I am. I'm having trouble finding both "Grasshopper" and "GH_IO" .dll. I can't find the "Illustrator.dll", but I did understand you about linking it below under "IllustratorInterface".

EDIT: I found both Grasshopper files by searching the whole C drive. They were in ProgramFiles > Common Files. "Illustrator.dll" still MIA.

I just found the illustrator reference. , here it is

Right click on References->  Add reference

After clicking on Add reference, a window popout, click on "COM", find Adobe illustrator CC Type Library, check it. and there are no error messages anymore.

This is the first time I am able to answer questions on grasshopper3d, so happy. 

and thank Andrew Heumann for developing awesome plugins!

Hi Chuck,

I have been using doodlebug for while now and this error popped:

1. Solution exception:Unable to cast COM object of type 'System.__ComObject' to interface type 'Illustrator.Application'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{95CD20AA-AD72-11D3-B086-0010A4F5C335}' failed due to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).

I have tried to rebuild the solution and add the references on VS, though the same error shows. Any tip on this one ?


ps: is it necessary to add all of these files to the Gh LIbraries folder?

installed Illustrator 2018, rebuilt solution with correct references and it's on!

Hi Oliver,

Would you mind sharing the files for the people that don't have VS, like me. :)

Sorry for the late reply, here is my build


I put together a video explaining step-by-step how to install doodlebug on which ever build you have. Also, I rebuilt the plugin for Rhino 6 and illustrator CC 2019. Both of which can be found here on my blog:


Hi Pmpetros,

Thank you for your solution. I tried but unfortunately failed. After switching .NET Framework to 4.5, the red checker mark won't go away. Any idea why did that happen? I have rhino 6 SR22 and Ai 2020 CC. 






  • Add Photos
  • View All


  • Add Videos
  • View All

© 2023   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service