Grasshopper

algorithmic modeling for Rhino

Hi,

thanks for great tool. Spending quite a bit of time learning :) Have a lot of questions, but one question at a time.

When I pipe a lattice, i.e. create surface around lattice beams, I noticed that with selected thickness it always goes beyond original shape. See attached image. How to overcome that and keep lattice within original shape? Am I doing something totally wrong here?

Goal here is to fill original STL mesh with lattice while preserving correct geometries. I am not sure if "Pipe" tool is the correct way of giving lattice beams actual surfaces as well, but when final "Bake" is made, it really goes beyond original.

Thanks.

Views: 291

Attachments:

Replies to This Discussion

Hi Vaidas,

Yes when you give a line thickness it adds a radius to the line. If that line is on the surface it will extend passed the surface by the radius you gave it.

There are options: Boolean cut away the piped lines to your surface. This will leave half the pipe there. The other option is create the lattice structure or skin of the lattice that is offset inside your structure so that the radius of the pipes are within your geometry. You could do this by offsetting your original geometry and using that as your trimming geometry.

Dear, Aaron. 

Thanks a lot, I will give it a try.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2023   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service