algorithmic modeling for Rhino

Hey everybody, I'm having trouble with grasshopper because whenever I double click on the VB Script Component to edit code rhino and grasshopper just close.  No error dialog or anything, they just close.  It is the same for the C#.NET Component.  I can't even open a file that has VB or CNET Script in it without the program just crashing.  Anybody experience something similar and if so how can I fix it?

Views: 462

Replies to This Discussion

Have you tried re-installing grasshopper!


That's very odd. It sounds like the problem is caused by an attempt to compile the code, but it's hard to be certain about this (if you create a new VB script component, no code is compiled yet). Which .NET framework do you have installed (if you can find out)? You might try (re)installing .NET 3.5, which is a free download from Microsoft.



David Rutten

Poprad, Slovakia

i reinstalled gh again .... but it didnt work... ihave  dot net 2.0... does gh 0.80010 need dot net 4?

Grasshopper on Rhino4 needs .NET 3.5, grasshopper on Rhino5 needs .NET 4.0


Rhino5 enforces .NET 4.0, but Rhino4 only enforces .NET 2.0, so there can be a problem with Grasshopper on Rhino4.



David Rutten

Poprad, Slovakia

installed both dot net 3.5 and 4.0 .... now it works... problem solved

Can I revive this thread to ask the same question?    VB and C# "edit source" crashes both GH and Rhino with no warning.    I'm running GH 9.0062 and .NET 4.5.   Any guesses?






  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service