algorithmic modeling for Rhino

Octopus cannot start computing - phenotype? too fast for loops?

Hello all,

I am having a problem with figuring out why Octopus cannot compute anything.

The case is sailing yacht's rig (mast, spreaders + steel lines) multicriteria optimisation.
The 1st criteria is to minimize the mass, the second to minimize the VCG (vertical center of gravity).
As a genotype for now I've connected only the number of spreaders (see picture below for explanation).

Two questions arises here:

1. The 1st thing is I am not sure what to connect to the Phenotype input.
In all the examples it is more straihg-forward - you plug in domain for points (i.e. surface) and the solution is a point.
In my case I change the number (of spreaders) and get all the geometry from the photo.

I tried to connect the whole geometry - so all lines that represent: mast, spreaders, steel lines,
but Octopus does not "want" to start - it seems that he calculates something - evaluation time displaying on the left etc.
But nothing appears on the chart.
From the other hand it doesn't crash either.

2. Judging on what I see in Rhino, Octopus rarely wait till GH finishes calculating the whole geometry.

The problem is it takes a while - I've usen "time buffer" component with delay set to 8(!) seconds, so all the loops finishes and total mass that appear is the final one.

Any ideas how I can make him wait?


Views: 199

Replies to This Discussion

Now I am sure that Octopus changes the parameter so fast that he does not get any data from GH.

Do you have any examples how to make the Octopus wait for the new result of fitness function after changing the sliders?

If anyone has a similar case - it was the delay component.
After cutting it off and connecting all geometry to phenotype Octopus has started,
although still not working properly - still haven't solved the 2nd problem.






  • Add Photos
  • View All

© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service