algorithmic modeling for Rhino

Hi all,

The new Chameleon ( is finally here, check it out!

  1. Chameleon now supports editing adaptive components it has previously placed.
  2. Chameleon Adaptive Component Systems (CACS) can be created, named, and edited later, (Added “AC Connect”, “AC System”, & “Load AC” functions).
  3. CACS created in one session of Revit can be re-loaded into the Grasshopper environment in another session.
  4. Utility commands in the Grasshopper & Revit environments have been de-commissioned, to reappear in a separate plugin.  Chameleon is focused on interoperability.
  5. The GBXML component now works without needing proper latitude, longitude, & city data.



Views: 3777

Replies to This Discussion

hey figured it out!!!!!!!!!!!! Always happens soon after i ask on forum! I had to open the addin file in notepad and in text rename "Release\ChameleonRVT.dll" to just "ChameleonRVT.dll" and there it is happily living in my add in bar!!!!!!!! Thanks for awesome plug in! 

Hello! Is anyone else having trouble downloading v0.4.0.0? I've tried on several different machines, every time I either get a "Current version.txt" or an invalid zip file (after inputting my email, etc). I can get the previous version no problem...



Hello mr jacobs, I am eager to try out your plug in. I have been trying to transfer / automate creating mullions or curtain wall familytype in revit with geometry from grasshopper. I have tried grevit, and hummingbird but not succesful so far. 

I seem to have problem with 0.4 release - when I hit AC connect from the grasshopper side, rhino and grasshopper crashes - and revit architecture 2014 is fine. 

I am using grasshopper 0.9.0056. How could I go about solving this problem?


Is there any word on when this might become available for the new 2015 version of Revit?

Has anyone tried to port this to the new version ?



yes I am also curious does chameleon work with Revit 2015? Thanks

Hi Hiroshi!!! I'm trying to download the last release of Chameleon but the .zip file downloaded after submit is only 7bytes, and can't open it, is invalid. Is there any other place to download it?? Thanks!!

Same problem here :)

I've got the same problem with the zip file as well. Trying to install the addin on Revit 2015. :)

Hmm, is it just me, or is the link coming up "invalid"?

Hi guys

Yep the webpage is down but furthermore, the software wasn't actually able to be downloaded since September 2014. It is also old and hasn't been been updated since 14 June 2013 (v0.4.0.0). Hiroshi doesn't seem to be replying to posts since then. I would say Chameleon is probably dead which is a shame. I would recommend trying one of the other plug-ins - Dynamo, Rhymano, Grevit or Hummingbird. Dynamo is the most powerful and will have the best longevity. 

Hey all

Chameleon works if you copy the install files from an earlier version like 2013 or 2014 into the 2015 addin directory.

However there is a serious issue I have where referenced geometry seems to scale by an unknown value, for example a 10m slab might come into Grasshopper as a 10.7m slab. Very strange and it makes it unusable, which is a shame because as Paul mentioned on the main Chameleon page, Chameleon is the only way to directly reference Revit content into Grasshopper, and has generally been an awesome app for some time now.

The closest alternative is using Mantis Shrimp, a plugin that operates between Dynamo and Grasshopper, but the workflow there is to reference Revit geometry into Dynamo, convert it to DesignScript, write it as a generic data exchange file, and then reference that file location in Grasshopper. A great workflow when you're already in Dynamo but obviously not as fast as what Chameleon is doing.

Paul is right - Dynamo has the most assured longevity of the interop tools and that's where we'll be shifting focus. Lyrebird was developed in partnership with McNeel and works through 2016 so there's some assurance there as well.

Hi Hiroshi,

I'm trying to download Chameleon but the website doesn't work!

I also tryed to go on "" but I've same result!

It is possible to have new link to download your plug in?!?







© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service