Grasshopper

algorithmic modeling for Rhino

Hello Djordje,

I am trying to test your new version and when I toggle the OSM Shapes Component to run, I get this error :

1. Solution exception:WindowsError

I attached the gh def, just in case.

Best,

Views: 475

Attachments:

Replies to This Discussion

Sorry I forgot to paste the log on your component :

"Runtime error (Win32Exception): WindowsError

Traceback:
line 503, in setupOsmconf_ini_File, "<string>"
line 650, in checkOsmShpFiles, "<string>"
line 1082, in script"

Hi Mathieu,

I opened your LocationGrabber03_Gismo3.gh file, and just one notice: things changed a bit since the last time we spoke: Now it is recommended to always have particular keys plugged to the requiredKeys_ input of the "OSM Shapes" component. This is not the source of your problem though, but still I mentioned it in case you solve your issue, and afterwards want to use the "OSM Shapes" component.

The current (Win32Exception): WindowsError is the very same error message that you reported back in February.
For some reason, your Windows is not allowing the Gismo "OSM Shapes" component to delete C:\MapWinGIS_installation_folder\gdal-data\osmconf.ini file.

You previously solved it by allowing the full access control to it, so I am not sure why it is not working now.
Windows 10 seems to be the most overprotected operating system among other Windows versions, at least judging by the questions people asked so far.

Maybe you can try to turn off all the services which prevent users from changing certain files, like UAC or maybe even your antivirus?

Try this:

1) Close your Grasshopper and Rhino.
2) Restart your PC
3) When it boots up again, in your Start menu's search box type: "UAC". Click on it, and a new User Account Control Settings window will open. Set the bar on the left to "Never notify".
4) Completely turn off your Antivirus.
5) Check once again if your access control to the C:\MapWinGIS_installation_folder\gdal-data\osmconf.ini file is still set to the values you previously reported in this post.
6) Right-click on "Rhino 5" icon and then choose: "Run as administrator".
7) When Rhino boots up, run Grasshopper, and open the newest create_3dbuildings_trees_streets.gh file from here.

If none of this helps, maybe you have some other application which deals with access to files on your system? Malware removal application or similar? Try turning it off too.

I'll keep in mind your instructions for the requiredKeys_ input, thanks for advice.

About the error on the osmconf.ini, I already check about the same previous error I had. But when I set the security of the file to Full Control access, the file is deleted when I try to run the component (so if you said that it's normal, first good thing). But even with that, I get this error on the component :

"Runtime error (IOException): Access to the path 'c:\Program Files\MapWinGIS\gdal-data\osmconf.ini' is denied.

Traceback:
line 508, in setupOsmconf_ini_File, "<string>"
line 650, in checkOsmShpFiles, "<string>"
line 1082, in script"

And now, I can't specify anything to the osmconf.ini file cause it no longer exist.

Edit : I just try by uncheck the Read Only toggle on the MapWinGIS folder and I get this :

"Runtime error (DirectoryNotFoundException): Could not find a part of the path 'c:\Program Files\MapWinGIS\MapWinGIS\gdal-data\osmconf.ini'.

Traceback:
line 419, in setupOsmconf_ini_File, "<string>"
line 650, in checkOsmShpFiles, "<string>"
line 1082, in script"

I'm not sure but it seems that gismo try to read in c:\Program Files\MapWinGIS\MapWinGIS but my installation is only at c:\Program Files\MapWinGIS\ (not a folder level after the first folder).

When you said:

"But when I set the security of the file to Full Control access, the file is deleted when I try to run the component"

The file is deleted by "OSM Shapes" component, not manually by you? Just to be sure I understand you correctly?

Yes, the file is deleted by OSM Shapes, when clicking on the toggle on the RunIt input

Thank you Mathieu.

Yes, the osmconf.ini file needs to be deleted, but then a new one needs to be created. In order to be able to do this, the "OSM Shapes" component first needs to read the current osmconf.ini file, delete it, and then make a new altered osmconf.ini file based on the old one.


Both the first (line 508, 650, 1082) and second error messages (419, 650, 1082) mean: I can not open the osmconf.ini file, it does not exist.

Did you try all the 7 steps I mentioned in the last reply?

Ok I understand, the new osmconf.ini must be created in c:\Program Files\MapWinGIS\MapWinGIS, isn't it ? So, the OSM Shapes create a new folder and a new file ?

I did you trick just now, and same error. I'm on a Win 10 Enterprise version, only difference with the last time where I was on a second laptop with Win 10 Pro. No Antivirus software on both, only Win Defender.

I try to modify the access and security on the folders where the file is located but no luck. Do you think it could be better to place the installation folder of MapWinGIS somewhere esle ? Like c:/dev as prompted when installing ?

Ok I understand, the new osmconf.ini must be created in c:\Program Files\MapWinGIS\MapWinGIS, isn't it ? So, the OSM Shapes create a new folder and a new file ?

No, the osmconf.ini file is created in the same C:\MapWinGIS_installation_folder\gdal-data folder, which is: C:\Program Files\MapWinGIS\gdal-data in your case, I assume.

 

It seems as now your system is allowing the deletion of the osmconf.ini file, but not the creation of a new osmconf.ini file.

Can we now try the following please:

1) Shut down both Grasshopper and Rhino
2) Restart your system.
3) Make sure you are logged in as Administrator once the Windows boots up.
4) When it boots up, again in your Start menu's search box type: "UAC". Click on it and check if the bar on the left is still set to "Never notify".
5) Download the osmconf.ini file attached below.
6) Check if downloaded osmconf.ini file has been blocked: right click on it, and choose "Properties". If there is an "Unblock" button click on it, and then click on "OK". If there is no "Unblock" button, just click on "OK".
7) Copy the osmconf.ini file to your C:\MapWinGIS_installation_folder\gdal-data folder
8) Right-click on "Rhino 5" icon and then choose: "Run as administrator".
9) Download and open the newest create_3dbuildings_trees_streets.gh file from here.

What happens?

Attachments:

Kind of miracle !

I reinstalled MapWinGIS at same location (c:\Program Files\MapWinGIS), give full access to all folders containing the osmconf.ini file (MapWinGIS itself and gdal-data), right-click > properties > security tab.

And now it works ! Sorry for bothering you

Glad you found the solution !!
Just if any other user has a similar problem, can you please be a bit more specific on the:

"give full access to all folders containing the osmconf.ini file (MapWinGIS itself and gdal-data)"

Does that mean that you set the permissions for two folders: "MapWinGIS" and "gdal-data"? And that is it? Set permissions for only those two folders?

I attached a screenshot to be more specific.

Right-click > Properties > Security Tab > Edit > Allow Full Control for all groups and user names

Repeat this for the MapWinGIS folder then for the gdal-data folder inside MapWinGIS, and once more for the osmconf.ini file inside gdal-data.

Attachments:

Thank you for the detailed reply and screenshot Mathieu!

So the permissions you showed in your screenshot have to be set for the "MapWinGIS" folder, "gdal-data" folder and "osmconf.ini" file? That is it?

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service