Grasshopper

algorithmic modeling for Rhino

Hi

I have a component that runs a Rhino command by

RhinoApp.RunScript()

The Rhino command works fine, but after running it, I can no more select things on the canvas. I only can zoom in & out, bot no way to drag or select anything.

(I have to close Rhino)

I think I'm doing something wrong ... any ideas ?

BTW, RhinoApp.RunScript() gives no problem in a C# script component.

Thanks

emilio

Views: 444

Reply to This

Replies to This Discussion

I'll need to see the component or some code so I can repeat this.

--

David Rutten

david@mcneel.com

Tirol, Austria

Are you by any chance triggering the script with a button? Could be a case of this: http://www.grasshopper3d.com/forum/topics/boolean-button-runscript

Try swapping it out for a boolean toggle and see if that alleviates the problem. 

Hi guys,

David, I attach the component.

Andrew, you're right, I was using a button.

A boolean toggle works fine.  :)

Thanks a lot !  Cheers.

emilio

p.s. forgot to mention: (GH 090056 - Rhino 5 07/17/2013 - Windows Vista Home Premium, SP2)

Attachments:

For completing this thread, here is a working solution:

http://www.grasshopper3d.com/forum/topics/boolean-button-runscript?...

... Huh ... I had forgot about this ... But is very good seeing that solved. :)

Thanks Florian !

RSS

Translate

Search Grasshopper

Photos

  • Add Photos
  • View All

© 2017   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service